Unix, Linux, DevOps , Cloud computing and BigData Knowledge-Base

0

Debian: DSA-4111-1: libreoffice security update

LinuxSecurity.com: Mikhail Klementev, Ronnie Goodrich and Andrew Krasichkov discovered that missing restrictions in the implementation of the WEBSERVICE function in LibreOffice could result in the disclosure of arbitrary files readable by the user who … Continue Reading — Debian: DSA-4111-1: libreoffice security update

0

MPV, the Command Line Video Player, is Considering a GUI

Command line video player MPV may soon have an official GUI.  Vincent Lang, the lead developer of the MPV media player project, has suggested the tool adopts one of the community-made MPV GUI front-ends available. The reason? To make MPV more accessible. “While most mpv developers (including myself) have...

0

Your first robot: The controller [3/5]

This article originally appeared on Kyle Fazzari’s blog and is the third installment in a series. This is the third blog post in this series about creating your first robot with ROS and Ubuntu Core. In the previous post you were introduced to the Robot Operating System (ROS),...

0

Debian LTS: DLA-1275-1: uwsgi security update

LinuxSecurity.com: It was discovered that the uwsgi_expand_path function in utils.c in Unbit uWSGI, an application container server, has a stack-based buffer overflow via a large directory length that can cause a denial-of-service (application crash) o… Continue Reading — Debian LTS: DLA-1275-1: uwsgi security update

0

Debian LTS: DLA-1274-1: exim4 security update

LinuxSecurity.com: Meh Chang discovered a buffer overflow flaw in a utility function used in the SMTP listener of Exim, a mail transport agent. A remote attacker can take advantage of this flaw to cause a denial of service, or potentially the execution… Continue Reading —...

0

Debian: DSA-4110-1: exim4 security update

LinuxSecurity.com: Meh Chang discovered a buffer overflow flaw in a utility function used in the SMTP listener of Exim, a mail transport agent. A remote attacker can take advantage of this flaw to cause a denial of service, or potentially the execution… Continue Reading —...

0

Debian: DSA-4109-1: ruby-omniauth security update

LinuxSecurity.com: Lalith Rallabhandi discovered that OmniAuth, a Ruby library for implementing multi-provider authentication in web applications, mishandled and leaked sensitive information. An attacker with access to the callback environment, such as… Continue Reading — Debian: DSA-4109-1: ruby-omniauth security update

0

Linux Plumbers Networking Track CFP

Linux networking maintainer David Miller has put out a call for proposals for a two-day networking track at this year’s Linux Plumbers Conference (LPC). “We are seeking talks of 40 minutes in length, accompanied by papers of 2 to 10 pages in le… Continue Reading...

0

Tromey: JIT Compilation for Emacs

On his blog, Tom Tromey looks at just-in-time (JIT) compilation for Emacs and what he has done differently in his implementation from what was done in earlier efforts. He also looks at potential enhancements to his JIT: “Calling a function in Emacs Lisp is quite expensive....

Follow

Get every new post delivered to your Inbox

Join other followers

Page 2595 of 2989